読者です 読者をやめる 読者になる 読者になる

(:3[kanのメモ帳]

個人ゲーム開発者kan.kikuchiのメモ的技術ブログ。月木更新でUnity関連がメイン。

Code signing is required for product type 'Application' in SDK 'iOS 10.0'【iOS】【トラブルシューティング】

iOS トラブルシューティング

このエントリーをはてなブックマークに追加

この記事でのバージョン
Xcode 8.0

はじめに

今回はXcode8でビルドした時に、

Code signing is required for product type 'Application' in SDK 'iOS 10.0'

f:id:kan_kikuchi:20160928134916p:plain


と表示される場合の対処法の一つです。


Xcodeをアップデートする前は問題なかったのに、アップデートしたらエラーが出た

という場合だと恐らくこの記事のやり方で解決できます。

対処法

エラーを無くすにはXcode上で二つの設定をします。


一つ目はGeneral-SigningにあるTeam

None以外の適当なのものにします。


f:id:kan_kikuchi:20160929130913j:plain


二つ目はBuild Settings-SigningにあるCode Signing Identity

Don't Code Sign以外の適当なものにします。


f:id:kan_kikuchi:20160929134858p:plain


以上で、エラーがなくなるかもしれません。


おわりに

Unityで書き出す時に自動化したい場合は

以下の記事が参考になるかもしれません。(未確認)